File diff 534f4fed39b6 → 399d04db873d
media-sound/madfuload/madfuload-1.2-r2.ebuild
Show inline comments
 
@@ -2,7 +2,7 @@
 
# Distributed under the terms of the GNU General Public License v2
 
# $Header: $
 

	
 
EAPI="2"
 
EAPI="7"
 
inherit eutils linux-info
 

	
 
DESCRIPTION="M-Audio DFU firmware loader for MobilePre, Ozone, Sonica and Transit USB audio interfaces"
 
@@ -14,15 +14,18 @@ SLOT="0"
 
KEYWORDS="~x86"
 
IUSE=""
 

	
 
PATCHES=(
 
	"${FILESDIR}/${P}-42-madfuload-rules.patch"
 
	"${FILESDIR}/${P}-fix-64-bit-implicit-declarations.patch"
 
	"${FILESDIR}/${P}-udevinfo-autotools.patch"
 
	"${FILESDIR}/${P}-udevinfo-configure.patch"
 
)
 

	
 
pkg_setup() {
 
	kernel_is le 2 6 8 && die "Kernel > 2.6.8 needed"
 
	linux-info_pkg_setup
 
}
 

	
 
src_prepare() {
 
	epatch "${FILESDIR}/${P}"-*.patch
 
}
 

	
 
src_install() {
 
	emake DESTDIR="${D}" install || die "install failed"
 
	dodoc README || die "adding documentation failed"