Files @ 534f4fed39b6
Branch filter:

Location: portage-overlay.git/x11-plugins/purple-discord/purple-discord-9999-r1.ebuild

chain
x11-plugins/purple-discord: add qr code bindings
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit git-r3

DESCRIPTION="Pidgin/Purple PRotocol PLugin for Discord"
HOMEPAGE="https://github.com/EionRobb/purple-discord"
EGIT_REPO_URI="${HOMEPAGE}"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="qrcode"

DEPEND="net-im/pidgin
dev-vcs/git
dev-libs/json-glib
qrcode? ( dev-libs/nss media-gfx/qrencode )"
RDEPEND="${DEPEND}"

src_compile() {
	emake USE_QRCODE_AUTH=$(usex qrcode 1 0)
}